Back to overview
Downtime

Blog is unavailable

Mar 27 at 12:55pm EDT
Affected services
blog.navitmoney.com

Resolved
Mar 27 at 01:01pm EDT

We have reverted the blog back to the correct version.

Created
Mar 27 at 12:55pm EDT

The Nav.it Blog is currently unavailable. We are working to restore functionality